Difference between revisions of "Configure cctbx.xfel from existing Phenix install"

From cctbx_xfel
Jump to: navigation, search
(Created page with "Much of the code to run ''cctbx.xfel'' is already bundled in the latest phenix installers. The only missing package is DIALS. Here's how to get ''cctbx.xfel'' configured fro...")
 
Line 3: Line 3:
 
Note: this only applies to processing individual stills.  Functionality to read XTC streams from LCLS is not included when using this procedure.
 
Note: this only applies to processing individual stills.  Functionality to read XTC streams from LCLS is not included when using this procedure.
  
Once Phenix is installed:
+
Once Phenix is installed and sourced correctly:
  
 
   cd <path to phenix installation>/modules
 
   cd <path to phenix installation>/modules
Line 11: Line 11:
 
   make
 
   make
 
   make
 
   make
 +
 +
prime.postrefine, one of the merging and scaling programs provided with ''cctbx.xfel'' requires scipy.  This can be installed with this command:
 +
 +
libtbx.python -m easy_install scipy
 +
 +
On linux, this may require openssl to be installed, if it's not already:
 +
 +
yum install openssl098e

Revision as of 13:33, 11 August 2015

Much of the code to run cctbx.xfel is already bundled in the latest phenix installers. The only missing package is DIALS. Here's how to get cctbx.xfel configured from an existing Phenix installation.

Note: this only applies to processing individual stills. Functionality to read XTC streams from LCLS is not included when using this procedure.

Once Phenix is installed and sourced correctly:

 cd <path to phenix installation>/modules
 svn co https://svn.code.sf.net/p/dials/code/trunk dials
 cd ../modules/build
 libtbx.configure xfel
 make
 make

prime.postrefine, one of the merging and scaling programs provided with cctbx.xfel requires scipy. This can be installed with this command:

libtbx.python -m easy_install scipy

On linux, this may require openssl to be installed, if it's not already:

yum install openssl098e